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2A. Android Environment: Eclipse & ADT

The Android Development Tools (ADT) plugin for Eclipse adds extensions 
to the Eclipse IDE. 
It allows you to create and debug Android applications easier and faster. 

Advantages
1. It gives you access to other Android development tools from inside the 

Eclipse IDE. For example: 
• take screenshots, 
• Debug / set breakpoints, and 
• view thread and process information directly from Eclipse.

2. It provides a New Project Wizard, which helps you quickly create and 
set up all of the basic files you'll need for a new Android application.

3. It automates and simplifies the process of building your Android 
application.

4. It provides an Android code editor that helps you write valid XML for 
your Android manifest and resource files.

5. It will export your project into a signed APK, which can be distributed 
to users.
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2A. Android Environment: Eclipse & ADT

Typical Layout of the Eclipse IDE for Android Development
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2A. Android Environment: Eclipse & ADT

Typical Layout of the Eclipse IDE for Android Development
(details…)
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Android SDK and AVD Manager
New Android Project

DDMS  Perspective
Dalvik Debugging Monitoring System
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2A. Android Environment: Eclipse & ADT
SETUP
Download the Android SDK – Installing on Windows, Linux, Mac OS
This page is taken from  http://developer.android.com

If you're already using the Android SDK, you should update to the latest tools or platform using 
the Android SDK and AVD Manager, rather than downloading a new SDK starter package. 

Windows installer_r08-windows.exe
Mac OS X (intel) android-sdk_r08-mac_86.zip
Linux (i386) android-sdk_r08-linux_86.tgz

Here's an overview of the steps you must follow to set up the Android SDK:

1. Prepare your development computer and ensure it meets the system requirements.
2. Install the SDK starter package from the table above. (If you're on Windows, download the 

installer for help with the initial setup.)
3. Install the ADT Plugin for Eclipse (if you'll be developing in Eclipse).
4. Add Android platforms and other components to your SDK.
5. Explore the contents of the Android SDK (optional).

To get started, download the appropriate package from the table above, then read the 
guide to Installing the SDK.
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2A. Android Environment: Eclipse & ADT

Installing the SDK  (Link: http://developer.android.com/sdk/installing.html)

This page describes how to install the Android SDK and set up your development 
environment for the first time.

Updating?
If you already have an Android SDK, use the Android SDK and AVD Manager tool 
to install updated tools and new Android platforms into your existing 
environment.

Step 1. Preparing Your Development Computer

1. Make sure you have already installed the most recent JDK. 

2. Make sure you have Eclipse installed on your computer (3.4 or newer is 
recommended). Eclipse is available from: http://www.eclipse.org/downloads/
(For Eclipse 3.5 or newer, the "Eclipse Classic" version is recommended)
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2A. Android Environment: Eclipse & ADT

Step 2. Downloading the SDK Starter Package
The SDK starter package is not a full development environment—it includes only 
the core SDK Tools, which you can use to download the rest of the SDK 
components (such as the latest Android platform).

If you downloaded the Windows installer (.exe file), run it now to install the SDK 
Tools into a default location (which you can modify, usually the folder is:
c:/your-chosen-path/android-sdk-windows

Make a note of the name and location of the SDK directory on your system—you 
will need to refer to the SDK directory later, when setting up the ADT plugin and 
when using the SDK tools from command line.

Step 3. Installing the ADT Plugin for Eclipse
Android offers a custom plugin for the Eclipse IDE, called Android Development 
Tools (ADT). This is the recommended platform. You may want to first read 
Installing the ADT Plugin for step-by-step installation instructions, then return 
here to continue the last step in setting up your Android SDK.
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2A. Android Environment: Eclipse & ADT

Step 4. Adding Platforms and Other Components
You will use the Android SDK and AVD Manager (a tool included in the SDK starter 
package) to download essential SDK components into your development 
environment.

If you used the Windows installer, when you complete the installation wizard, it 
will launch the Android SDK and AVD Manager with a default set of platforms and 
other components selected for you to install.  Simply click Install to accept the 
recommended set of components and install them. 

You can launch the Android SDK and AVD Manager in one of the following ways:
From within Eclipse, select Window > Android SDK and AVD Manager.
On Windows, double-click the SDK Manager.ext file at the root of the Android 
SDK directory.

On Mac or Linux, open a terminal and navigate to the tools/ directory in the 
Android SDK, then execute: android
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2A. Android Environment: Eclipse & ADT

Step 4. Adding Platforms and Other Components (cont.)
To download components, use the graphical UI of the Android SDK and AVD Manager.
To begin with choose only the latest version of Android (include documentation, 
samples and USB driver)  (Warning: this process is slow…)

Figure 1. The Android SDK and AVD Manager's Available Packages panel, which shows 
the SDK components that are available for you to download into your environment.
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2A. Android Environment: Eclipse & ADT

Installing the Eclipse ADT Plugin

(Link: http://developer.android.com/sdk/eclipse-adt.html#installing)

To simplify ADT setup, it is recommend installing the Android SDK prior to installing ADT.

Eclipse 3.5 (Galileo) and 3.6 (Helios)
1. Start Eclipse, then select Help > Install New Software....
2. Click Add, in the top-right corner.
3. In the Add Repository dialog that appears, enter "ADT Plugin" for the Name and 

the following URL for the Location:
https://dl-ssl.google.com/android/eclipse/
Note: If you have troubles try using "http" instead of "https”
Click OK.

4. In the Available Software dialog, select the checkbox next to Developer Tools and 
click Next.

5. In the next window, you'll see a list of the tools to be downloaded. Click Next.
6. Read and accept the license agreements, then click Finish.
7. When the installation completes, restart Eclipse.
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2A. Android Environment: Eclipse & ADT

Configuring the ADT Plugin

The next step is to modify your ADT preferences in Eclipse to point to the 
Android SDK directory:

1. Select Window > Preferences... to open the Preferences panel 
(Mac OS X: Eclipse > Preferences).

1. Select Android from the left panel.
2. For the SDK Location in the main panel, click Browse... and locate 

your downloaded SDK directory (c:/path/android-sdk-windows)
3. Click Apply, then OK.

Done! 
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2A. Android Environment: Eclipse & ADT

Creating an Android Virtual Device (AVD)

Android Virtual Devices (AVDs) are configurations of emulator options that let 
you better model an actual device.
1. In Eclipse, choose Window > Android SDK and AVD Manager. 
2. Select Virtual Devices in the left panel.
3. Click New.
4. The Create New AVD dialog appears.
5. Type the name of the AVD, such as “AVD23API9".
6. Choose a target (such as “Android 2.3 – API Level9”).
7. Optionally specify any additional settings 

(SD, camera, trackball, ….) YES to all.
8. Click Create AVD.
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2A. Android Environment: Eclipse & ADT

Testing the Emulator

Android Virtual Devices (AVDs) are configurations of emulator options that let 
you better model an actual device.
1. In Eclipse, choose Window > Android SDK and AVD Manager. 
2. Select Virtual Devices in the left panel.
3. Click on an AVD 
4. Click Start.
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2A. Android Environment: Eclipse & ADT

A Final Step

This seems to be a transitional issue, and may go away in future releases. For 
now, update the system’s PATH variable to recognize two folders inside your 
android-sdk-winwows. The first is: tools and the second is platform-tools. 

1. Windows > Start > Control Panel > System > Advanced > Environment 
Variables > System Variables > PATH > Edit

2. Add references to the sub-folders mentioned above. In this example: 
c:\android-sdk-windows\tools;C:\android-sdk-windows\platform-tools;

3. OK
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Android Setup Videos

Appendix. Web resources available at

http://www.hometutorials.com/google-android.html

Five videos, a bit older (SDK1.0) but useful nonetheless.

1. How to setup Java.

2. How to install Eclipse IDE

3. Application development: “Hello World” using Eclipse 
+ Android
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Android Setup Tutorial
MAC OS Users
1. In a terminal window send the command: sudo su. You will act as the superuser.

1. Enter superuser’s password. After accepted, you will issue commands from a shell line.

2. Locate the file .profile and edit (pico, vi,…) its path contents as follows:

export PATH="/Users/myfolder/android-sdk-mac_86 3/tools":$PATH

where "/Users/myfolder/android-sdk-mac_86 3/tools" (including the quotes) is the location 
of the /tools directory in our Android SDK folder.
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Android Setup Tutorial
Appendix.  Install Java
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1. Go to http://developers.sun.com/downloads/
2. Expand choice Java SE. 
3. Click on:  Java SE (JDK) 6 
4. From the list of choices select the most recent Java SE JDK (Update 14 in our case).
5. Click on the Download button

http://developers.sun.com/downloads/


Android Setup Tutorial
Appendix. Install Java
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1. On the next screen select Platform (Windows) and accept license agreement.
2. Hit the Continue button.
3. Check box: Java SE Development Kit 6u14 and click on the download (arrow) symbol
4. Save file to c:\



Android Setup Tutorial
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5. Execute the downloaded file: jdk-6u14-windows-i586.exe 
6. Click on Accept button to agree on licensing.
7. Note the Java folder location. Click on Next to complete installation.

Appendix.  Install Java
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Eclipse is a multi-language software development 
platform comprising an IDE and a plug-in system to 
extend it. It can be used to develop applications in Java 
and, by means of the various plug-ins, in other 
languages (from Wikipedia)

1. Go to http://www.eclipse.org/downloads/. 
2. Download the current version (Galileo at the time of 

writing) and save it to drive C:\. 
3. Unzip the compress file to your hard drive (c:\eclipse)
4. For convenience create a Shortcut to eclipse.exe and 

place it on your Desktop.

Appendix. Install Eclipse IDE

http://www.eclipse.org/downloads/
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1. Launch eclipse application.
2. Create a folder to be your workspace

Appendix. Install Eclipse IDE
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Appendix. Creating an Android Project  (made for 1.5)

Reference:  http://developer.android.com/guide/developing/eclipse-adt.html

Hola Mundo

http://developer.android.com/guide/developing/eclipse-adt.html
http://developer.android.com/guide/developing/eclipse-adt.html
http://developer.android.com/guide/developing/eclipse-adt.html
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Creating an Android Project 
To create a new project:
1. Start Eclipse
2. Select File > New > Project.
3. Select Android > Android Project, 

and click Next.
4. Enter Project name: AndHolaMundo.
5. Select Target Android  1.5.
6. Application name: Hola.
7. Package name: cis493.demo.
8. Create Activity: HolaMundo.
9. Min SDK Version: 3.
10. Click Finish.
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Creating an Android Project 
Once you complete the New Project Wizard, ADT creates the following folders and 
files in your new project:

• src/ Includes your stub Activity Java file. All other Java files for your application 
go here. 

• <Android Version>/ (e.g., Android 1.5/) Includes the android.jar file that your 
application will build against. 

• gen/ This contains the Java files generated by ADT, such as your R.java file and 
interfaces created from AIDL files. 

• assets/ This is empty. You can use it to store raw asset files. 
• res/ A folder for your application resources, such as drawable files, layout files, 

string values, etc.
• AndroidManifest.xml The Android Manifest for your project. 
• default.properties This file contains project settings, such as the build target. 
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Creating an Android 
Project 
Once you complete the New 
Project Wizard, ADT creates the 
following folders and files in your 
new project:
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Creating an Android Project 
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Creating an Android Project  - Debugging
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package matos.demo;

import android.app.Activity;

import android.os.Bundle;

import android.widget.Toast;

public class HolaMundo extends Activity {

/** Called when the activity is first created. */

@Override

public void onCreate(Bundle savedInstanceState) {

super.onCreate(savedInstanceState);

setContentView(R.layout.main);

for (int i=0; i<3;  i++){

Toast.makeText(getApplicationContext(), i + " Hola Mundo", 1).show();        

}

Toast.makeText(getApplicationContext(), " Adios", 1).show(); 

}

}

Creating an Android Project 
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Creating an Android Project 
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Questions ?
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0. JAVA
http://www.dailymotion.com/video/x77uqg_google-android-emulator-tutorial-tr_tech

1. ECLIPSE
http://www.dailymotion.com/related/x77v5t_google-android-eclipse-adt-tutorial_tech/video/x77usr_google-android-eclipse-tutorial-tra_tech

2. ANDROID-SDK
Android ADT Eclipse Plug-in link: https://dl-ssl.google.com/android/eclipse/
http://www.dailymotion.com/related/x77v5t_google-android-eclipse-adt-tutorial_tech/video/x77uou_google-android-sdk-emulator-tutoria_tech

3. ECLIPSE-PLUGIN
http://www.dailymotion.com/related/x77usr_google-android-eclipse-tutorial-tra_tech/video/x77v5t_google-android-eclipse-adt-
tutorial_tech?from=rss

4. HELLO WORLD TUTORIAL
http://www.dailymotion.com/video/x77v6w_google-android-apps-tutorial-traini_tech

5. DROID_DRAW
http://www.droiddraw.org

6. MAKING SDCARD (Video, blogs)
http://www.anddev.org/emulating_a_sd-card-t263.html
http://groups.google.com/group/android-developers/browse_thread/thread/9d068936b43c5f27
http://www.anddev.org/problem_pushing_files_onto_sdcard-t2467.html

7. Three GOOD videos from Google (Architecture, Interprocess Comm, APIs)
1.  http://www.youtube.com/watch?v=QBGfUs9mQYY&eurl=http://developerlife.com/theblog/?p=454
2. http://www.youtube.com/watch?v=fL6gSd4ugSI&feature=related
3.  http://www.youtube.com/watch?v=MPukbH6D-lY&feature=related

8. More APPs  (Google President, HelloWorld, PhoneLocator)
http://www.youtube.com/watch?v=1FJHYqE0RDg&feature=channel
http://www.youtube.com/watch?v=I6ObTqIiYfE&feature=channel
http://www.helloandroid.com/taxonomy/term/29
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Appendix A.  
Android Virtual Devices
An AVD tells the emulator what kind of device it is suppose to impersonate. 
Currently there are a few of these targets, such as:

Target
Level

Description

4 Identifies an Android 1.6 device that has Google Maps support 
[mostly all new Android devices after 2008]

9 Identifies an Android 2.3 device that has Google Maps support 
[mostly all new Android devices after 2010+ ]
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Appendix A.   Cont
Android SDK Targets (2.x and newer versions)
You may use the UI app to inspect available components and download target platforms.

Downloading
This is a three-steps operation. First install the (empty) SDK shell as indicated above (download and 
unzip). Second update the path system variable to include the path to: android-sdk-windows\tools. 
Third: access the repository, select and download the specific targets.
How?
At the console prompt type in the command
C:> android 

To add SDKs click on 
Available Packages

Use the https://..... URL
(or equivalent but less secure 
http://.... Locator )

Follow instructions to accept
Licensing. Wait (slow …)


